#SharePoint 2013 Installation Problem, Error when installing AppFabric 1.1 on Server 2012 64bit

One of the Common errors that someone may face while installing SharePoint 2013 prerequisites of AppFabric application, is the error of:

“AppFabric installation failed because installer MSI returned with error code : 1603 ”

(Step 1)

This error may occurs due to many reasons, one of them is PSModulePath corruption, you may try to check the ” EnvironmentVariables“, and check the value of PSModulePath; find it here:

System Properties -> Environment Variables -> System Variables.

And check its value to be exactly like that: ( %SYSTEMROOT%\System32\WindowsPowerShell\v1.0\) without braces, if it was written correctly if not, just correct it, and then try your setup gain, if it not working for you, then you should do the following:

(Step 2)

Open you Server Manager and from Tools menu open Computer Management:

 

Or just type in Run command: Compmgmt.msc , and it will open Computer Management for you.

Then check groups and find if these two groups are existed : AS_Administrators and AS_Observers Security Groups , if so,  just delete them, as it was added by AppFabric setup program and recheck your installation again, it should now work for you:

And the result after doing the above steps should be like that:

Advertisements

About Hossam Kamal

Hossam Kamal Senior SharePoint Developer with high development skills in C#, ASP.NET, SharePoint Server Technologies, jQuery, CSS, XML, O.O.D, SSRS and MS.SQL Server.
This entry was posted in SharePoint General. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s